It is currently Fri Sep 22, 2017 12:33 am


All times are UTC - 5 hours [ DST ]


Register for Windows Forums


New posts Register

Register for Windows Forums now to gain access to: post messages, download free books, competitions for great prizes, and get to know others. Members also see NO ADVERTS. Join today!




 Page 2 of 2 [ 17 posts ]  Go to page Previous  1, 2
Message Author
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)
New postPosted: Wed Nov 03, 2010 5:00 pm 

I've Restarted. Didn't help. Windows says that the driver I have is the most suitable... but is using the generic USB driver (6.1.7600.16385 with usb.inf) - for sure is not correct (and still has the 'unknown device' tag). Somehow I need to make it 'understand' it's a webcam and use its correct inf (maybe is "R5U870FL.inf" - I saw that inf in the 2 drivers I've tried to install (see my first post)).

Maybe someone with Sony Vaio VGN-Zxxx and Win7 x64 can check the inf file and the driver's files his laptop is using?

Thanks,



_________________
Alon
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Established Member
Established Member

Joined: Sat Aug 29, 2009 12:55 pm
Posts: 10
Thanks given: 0 times
Thanks received: 1 times
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)  Topic is solved
New postPosted: Fri Nov 05, 2010 10:30 am 
For this post the author Alon has received gratitude : Stu

Wooohooooooooooooooo!!! I've solved it!!!!!! :D :D :D :D :D :D :D :D :D :D

The procedure I've done is the follwoing:

1. Insatll the "Sony Visual Communication Camera Driver 6.201.220.0 Windows XP" that I've found over the internet belongs to other Sony VGN models. It has model protection, so you have to open it with the wonderfull application "Universal Extractor" (that helped me when I've installed the Win7 before Sony published its drivers). You can download the file from here or just search by its name.
2. Restart the machine (several times if needed) till the 'Imaging Devices' entry will reappear in the device list with the "Sony Visual Communication Camera" device in it. On this phase, when testing the camera (in Skype or ArcSoft ebcam companion) you will get a black screen and a message saying the camera is not working correctly (earlier, the message was that a camera does not exist...).
3. Then (DRUMS ROLLING) I took the usbvideo.inf and usbvideo.sys files (see attached below) from a guy I met with Sony VGN-Z820 and replaced them with the ones in my laptop. The amazing thing is that the inf file was exactly the same and the sys file had exactly th same size (up to the byte). Replacing the files also took some process:
3.a. Go to "C:\Windows\inf" and change the usbvideo.pnf and usbvideo.inf file names to usbvideo1.pnf and usbvideo1.inf
3.b. Paste the usbvideo.inf I attached here to "C:\Windows\inf".
3.c. Open "C:\Windows\System32\drivers" and change the file owner of "usbvideo.sys" file from TrustedInstaller to yourself or alike (if you dont know how - check here), then you can change its name to usbvideo1.sys.
3.d. Paste the usbvideo.sys I attached here to "C:\Windows\System32\drivers".
4. Go to "Device Manager" and update the "Sony Visual Communication Camera" device driver by pointing to the new usbvideo.inf file.
5. Voila, you have the webcam working and the "Sony Visual Communication Camera" device changed its name to "USB Video".

Attachment:
New usbvideo inf & sys.7z


You do not have the required permissions to view the files attached to this post.



_________________
Alon
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Established Member
Established Member

Joined: Sat Aug 29, 2009 12:55 pm
Posts: 10
Thanks given: 0 times
Thanks received: 1 times
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)
New postPosted: Fri Nov 05, 2010 11:34 am 

Thanks for sharing your solution Alon. :geek:



_________________
Image
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Site Admin
Site Admin
Windows Guru²
Windows Guru²

Joined: Sat Jun 07, 2008 9:08 am
Posts: 3186
Thanks given: 375 times
Thanks received: 441 times
Location: 0x7C00
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)
New postPosted: Fri Nov 05, 2010 11:46 am 

rsvr85 wrote:
Thanks for sharing your solution Alon. :geek:


You and everyone are most welcomed. I must tell you, there are some solutions in the web for the VGN-CR... but none for the Z series. None. As much as I like the Sony laptops, Sony's drivers support is really lousy. We depend solely on the community.



_________________
Alon
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Established Member
Established Member

Joined: Sat Aug 29, 2009 12:55 pm
Posts: 10
Thanks given: 0 times
Thanks received: 1 times
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)
New postPosted: Fri Nov 05, 2010 11:54 am 

A lot of big manufacturers scrimp on driver support. Why? Who knows. It can be bad enough getting up-to-date x86 drivers for some hardware. Running a x64 system on top of that? Good luck.
Having to install drivers that were intended for XP on a Windows 7 system in this day and age, is not good.



_________________
Image
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Site Admin
Site Admin
Windows Guru²
Windows Guru²

Joined: Sat Jun 07, 2008 9:08 am
Posts: 3186
Thanks given: 375 times
Thanks received: 441 times
Location: 0x7C00
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)
New postPosted: Fri Nov 05, 2010 12:05 pm 

Totally agree.



_________________
Alon
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Established Member
Established Member

Joined: Sat Aug 29, 2009 12:55 pm
Posts: 10
Thanks given: 0 times
Thanks received: 1 times
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Webcam (motion eye) stopped working (Sony VGN-Z790 Win7 x64)
New postPosted: Fri Sep 14, 2012 11:30 pm 

Hi Alon

I have been searching for solutions to this problem for a long time now, and yours was the most detailed solution I have found.
My version is VPCEA45FG with Windows 7 Home Premium. I went through all the steps you have given, but it didn't work for me. Maybe having a different model is the reason? Any ideas?

Best
Laina


Years of membershipYears of membershipYears of membershipYears of membershipYears of membership
New Kid on the Block
New Kid on the Block

Joined: Fri Sep 14, 2012 10:36 pm
Posts: 1
Thanks given: 0 times
Thanks received: 0 times
Location: Delhi
 Profile E-mail  
 
Offline
Display posts from previous:  Sort by  
 Page 2 of 2 [ 17 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  

cron