It is currently Fri Nov 28, 2014 9:01 pm


All times are UTC - 5 hours [ DST ]


Register for Windows Forums


New posts Register

Register for Windows Forums now to gain access to: post messages, download free books, competitions for great prizes, and get to know others. Members also see NO ADVERTS. Join today!




Message Author
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Wed Oct 12, 2011 2:45 pm 
For this post the author Rick has received gratitude : Frank D

Makcalable wrote:
Ok Frank I would then go for a startup Repair using the Windows 7 Install DVD
.

What to do is follow this short Guide only up until the point of the Startup Repair step by step ends.

Click Here


And check out Here too

Also it is possible that there is software that maybe conflicting with the sfc /scannow also.

Are you getting any specific error codes?

Could you also check out the Event Viewer to see if you have any error codes or information in there about your issue.


You can try this also

This can sometimes happens if the TrustedInstaller (Windows Modules Installer) service is or has been disabled;

1. Click Start, type Services.msc

2. Double Click Windows Modules Installer

3. Set its Startup type to Manual

4. Click OK.



The only code he got was: "Windows Resource Protection could not perform the requested operation" So, there is no specific error message or code.

The best way to look at it is the CBS file log, but he claim to say it doesn't have anything in it.

I would suggest: chkdsk /r first before doing the reinstllation to fix errors, or try to use a Restore Point... and Test the sfc /scannow to see if it worked...

Just my two cents....



_________________
~Rick
Quote: "If at first you don't succeed, Destroy all evidences you have tried"
Years of membershipYears of membershipYears of membershipYears of membershipYears of membershipYears of membership
User avatar
Windows Guru
Windows Guru

Joined: Sat Aug 23, 2008 11:38 am
Posts: 1306
Thanks given: 33 times
Thanks received: 137 times
Location: Underworld Realm
OS: 8 Pro
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Wed Oct 12, 2011 3:04 pm 
For this post the author Makcalable has received gratitude : Frank D

Well firstly Rick, as in Error's yes the CBS.log should hold details but as I read it doesn't. I was mearly asking for any additional error's that he may have encountered.

However... the Event Viewer will show up all Error's if any within the Error log of the Event Viewer and possibly more so I suggested this as it may shed more light on this issue. The Event Viewer is a very important Tool in Windows only it doesn't get used as much as it should.

And who was talking about a 'Re installation'???? Certainly not me, I suggested a startup repair so don't get the 2 mixed up as these methods are totally 2 different things.


As for a chkdsk well even there there were Error's within, it wouldn't necessarily effect the system file scan.

I have also mentioned a fix for the Windows Modules Installer which can also be a cause for the system file scan not working.


Now seeing as we are all working as a team I don't see the purpose of knocking someone else's suggestions unless there are ridiculous ones.



_________________
Image
Years of membershipYears of membershipYears of membershipYears of membership
User avatar
Top Content Contributor
Top Content Contributor

Joined: Mon Nov 15, 2010 7:20 pm
Posts: 565
Thanks given: 47 times
Thanks received: 132 times
Location: UK
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Wed Oct 12, 2011 6:54 pm 

Makcalable and Rick,

You're both giving me some good suggestions and I'd like to answer them one by one.

Makcalable: "Ok Frank I would then go for a startup Repair using the Windows 7 Install DVD"

Frank: I did that. No change.

"Also it is possible that there is software that maybe conflicting with the sfc /scannow also."

Frank: Can't imagine what. I don't do unusual stuff.

"Are you getting any specific error codes?"

No error codes. What you see in my posted link and attachment are all I get.

"Could you also check out the Event Viewer to see if you have any error codes or information in there about your issue."

Frank: Here is a screenshot of my latest Event Viewer window: http://gyazo.com/bc626032d7ae1a969357e1ce435d5f45 . I don't know what to make of it.

"This can sometimes happens if the TrustedInstaller (Windows Modules Installer) service is or has been disabled."

Frank: No, it's set to Manual. I've never changed it.

Rick said:
"The only code he got was: "Windows Resource Protection could not perform the requested operation" So, there is no specific error message or code.

"The best way to look at it is the CBS file log, but he claim to say it doesn't have anything in it."

Frank: Both are correct. (The CBS file didn't have a single character in it.)

"I would suggest: chkdsk /r first before doing the reinstllation to fix errors, or try to use a Restore Point... and Test the sfc /scannow to see if it worked..."

Frank: I did a chkdsk /r /f (took about 2 hours) and it fixed a few errors, but it didn't change anything in the sfc.

Then Makcalable said: "the Event Viewer will show up all Error's if any within the Error log of the Event Viewer and possibly more so I suggested this as it may shed more light on this issue. The Event Viewer is a very important Tool in Windows only it doesn't get used as much as it should."

Frank: I posted a link to a screenshot of the Event Viewer above.

"As for a chkdsk well even there there were Error's within, it wouldn't necessarily effect the system file scan."

Frank: That appears to be true.

That summarizes things as they are right now. I'm now at the point where my machine is working very well except for not being able to run sfc /scannow. So if you'd like, we can quit here, and I thank you for your help. :)

Frank


Years of membershipYears of membershipYears of membership
User avatar
Frequent Member
Frequent Member

Joined: Mon Jan 31, 2011 3:17 pm
Posts: 41
Thanks given: 30 times
Thanks received: 6 times
Location: New York, USA
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Wed Oct 12, 2011 7:45 pm 
For this post the author Makcalable has received gratitude : Frank D

Ok Buddy, you have a few issues don't you....

Well I am going to suggest a running a full scan of your System for Malware/Viruses - Click Here and Here


Also I would like you to take a read throught this link here - http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/sfcscannow-windows-resource-protection-could-not/a59f1690-6045-4820-a5b4-c35df7e5c4f7



On another note;

viewtopic.php?p=27638#p27638

Could lets us know how you got on at this link above by posting at that thread please, just curious ;-)



_________________
Image
Years of membershipYears of membershipYears of membershipYears of membership
User avatar
Top Content Contributor
Top Content Contributor

Joined: Mon Nov 15, 2010 7:20 pm
Posts: 565
Thanks given: 47 times
Thanks received: 132 times
Location: UK
OS: 8 RT
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Wed Oct 12, 2011 8:01 pm 

Makcalable wrote:
Ok Buddy, you have a few issues don't you....

Well I am going to suggest a running a full scan of your System for Malware/Viruses
<snip>
Also I would like you to take a read throught this link here -
<snip>

On another note;
viewtopic.php?p=27638#p27638

Could lets us know how you got on at this link above by posting at that thread please, just curious ;-)

OK, I'll try to do all that. Before I do, I'll just say that I've run SuperAntiSpyware, Malwarebytes Antimalware, SpyBot S&D, Advanced SystemCare, and a couple more with no results worth talking about. I'll need some time to run your suggested programs, and I'll get back to you with the results. :)

Frank


Years of membershipYears of membershipYears of membership
User avatar
Frequent Member
Frequent Member

Joined: Mon Jan 31, 2011 3:17 pm
Posts: 41
Thanks given: 30 times
Thanks received: 6 times
Location: New York, USA
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Thu Oct 13, 2011 12:49 am 
For this post the author flipboodle has received gratitude : Frank D

Hello, new here. Hi everyone.

Just to jump right in and avoid any kind of established protocol here, so please, pardon my "French". Delete as needed, etc. Sorry in advance - I like to talk and listen to myself ;-)

Had this same problem on my laptop on 10/04/11.
On 10/05/11 my kid's laptop went wonky too with the scannow issue. Suspicious of this, I tried peforming scannow on my PC and it worked fine. Then I realized the 2 laptops were on auto updates from windows and began to wonder.
Decided to update the PC and voila - it too could no longer perform scannow!
Did a system restore to no avail - scannow was MIA. Realizing this "might" be a windows update issue, I called a friend who also never updates and requested the unthinkable of him - do scannow and then do an update. Bingo - same problem after reboot and system restore was not accomodating any recovery.

So, now it was time to call windows in India!
Managed to talk my way into some "free" help from the call center in India (for Microsoft/windows, Bank of America... etc). They are really nice people and after chatting with "Phil" for about 20 minutes he decided to help me figure out the impossible - a possible bad update from windows. While my call was not official (I don't have an account and did not pay for Phil's excellent service), Phil certainly went beyond what is usually "customer care" for the paying customers. In 20 minutes additional chatting, Phil had managed to locate a friend of his (not an employee of the call center) who was, or had, experienced the same issue described herein. Scannow AND chkdsk were wonky for no apparent reason.

The solution the friend gave Phil who passed it on to me was simple and worked and might work for some here as well. (It also worked for my friend who I called first and asked to repeat my steps previously above).

Rebooted and hit F12 (might be different for others) and got into the boot options.
Selected Windows Recovery and then "Repair Windows"
When the menu of options appeared I selected Command Prompt and did a scannow. Worked perfectly! Then did chkdsk (all flavors, s, r, etc) and it worked perfectly too.

Rebooted and tried it in windows and perfect score again. Haven't had the problem since. tried it on both laptops, all perfect now.

I owe "Phil" a nice dinner, drinks and an introduction to a woman he can marry, next time I'm in India! Thanks Phil and good luck folks!


Years of membershipYears of membershipYears of membership
User avatar
New Kid on the Block
New Kid on the Block

Joined: Tue Sep 27, 2011 12:56 am
Posts: 1
Thanks given: 0 times
Thanks received: 1 times
Location: here, duh
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Thu Oct 13, 2011 1:44 am 

Frank D wrote:
UVAIS,
re:
UVAIS wrote:
Please try in safe mode
Or use same command in Hidden Admin acc ;
Run CMD as Admin and use this command
net user administrator /active:yes


I tried both of your suggestions but unfortunately got the exact same response in each case. :cry:

Frank


ohh i think your System is corrupted :think: try Mak's suggestion :thumbup:



_________________
Image
Years of membershipYears of membershipYears of membershipYears of membership
User avatar
Contributor
Contributor
Windows Guru
Windows Guru

Joined: Sat Aug 21, 2010 2:08 pm
Posts: 1505
Thanks given: 121 times
Thanks received: 263 times
Location: UVAIS-PC
OS: 7 Ultimate
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Thu Oct 13, 2011 6:11 pm 

Flipboodle,

Thanks for your tip. I tried it twice. Unfortunately nothing changed. Still hung, with no sfc capability.

Frank


Years of membershipYears of membershipYears of membership
User avatar
Frequent Member
Frequent Member

Joined: Mon Jan 31, 2011 3:17 pm
Posts: 41
Thanks given: 30 times
Thanks received: 6 times
Location: New York, USA
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Thu Oct 13, 2011 6:33 pm 

Makcalable wrote:
Well I am going to suggest a running a full scan of your System for Malware/Viruses - Click Here
OK, part of the story can be told. I ran the Malwarebytes Antimalware as instructed and it found a few "bad actors," but nothing of note, to me. Most were (as I recall) false hits from NirSoft Utilities. When I opened the log after the second run-through (after rebooting into normal Windows mode), there was nothing in it, other than the fact that it ran today, at this time, etc. When I looked in the Quarantine area, there wasn't anything there from today. I can't figure that out. But that's the story.

One more thing. I rechecked the CBS.log (from about 1 pm to 4 pm this after noon, and I'm going to attach the contents to this post. (This was from before I ran the Malwarebytes.)

Next I'm going to follow up on the second link from your post, above, and get back to you again.

Frank

P.S. The file wouldn't upload or attach (I just can't seem to get it to work), so I'm going to post the text below. Hope it helps.

CBS.log contents:
2011-10-13 12:57:22, Info CBS Reboot mark refs incremented to: 1
2011-10-13 12:57:22, Info CBS Scavenge: Starts
2011-10-13 12:57:22, Error CSI 000005e5@2011/10/13:16:57:22.487 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 12:57:24, Info CBS Scavenge: Failed to get CSI store for scavenging. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 12:57:24, Info CBS Warning: Failed to scavenge CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 12:57:24, Info CBS Reboot mark refs: 0
2011-10-13 12:57:24, Info CBS Warning: Failed while executing service idle processing. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 12:57:24, Info CBS Warning: Failed to execute service idle processing. Error code: 0X80073712 [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 12:57:24, Info CBS Idle processing thread terminated normally
2011-10-13 12:57:24, Info CBS Ending the TrustedInstaller main loop.
2011-10-13 12:57:24, Info CBS Starting TrustedInstaller finalization.
2011-10-13 12:57:24, Info CBS Ending TrustedInstaller finalization.
2011-10-13 16:07:13, Info CBS Starting TrustedInstaller initialization.
2011-10-13 16:07:13, Info CBS Loaded Servicing Stack v6.1.7601.17592 with Core: C:\Windows\winsxs\amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_672ce6c3de2cb17f\cbscore.dll
2011-10-13 16:07:18, Info CSI 00000001@2011/10/13:20:07:18.252 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7feef72f0ad @0x7fef1da9849 @0x7fef1d734e3 @0xffe1e97c @0xffe1d799 @0xffe1db2f)
2011-10-13 16:07:18, Info CSI 00000002@2011/10/13:20:07:18.272 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7feef72f0ad @0x7fef1df6816 @0x7fef1dc2aac @0x7fef1d735b9 @0xffe1e97c @0xffe1d799)
2011-10-13 16:07:18, Info CSI 00000003@2011/10/13:20:07:18.274 WcpInitialize (wcp.dll version 0.0.0.6) called (stack @0x7feef72f0ad @0x7fef5c08738 @0x7fef5c08866 @0xffe1e474 @0xffe1d7de @0xffe1db2f)
2011-10-13 16:07:18, Info CBS Ending TrustedInstaller initialization.
2011-10-13 16:07:18, Info CBS Starting the TrustedInstaller main loop.
2011-10-13 16:07:18, Info CBS TrustedInstaller service starts successfully.
2011-10-13 16:07:18, Info CBS SQM: Initializing online with Windows opt-in: False
2011-10-13 16:07:18, Info CBS SQM: Cleaning up report files older than 10 days.
2011-10-13 16:07:18, Info CBS SQM: Requesting upload of all unsent reports.
2011-10-13 16:07:18, Info CBS SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]
2011-10-13 16:07:18, Info CBS SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]
2011-10-13 16:07:18, Info CBS SQM: Queued 0 file(s) for upload with pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6
2011-10-13 16:07:18, Info CBS SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]
2011-10-13 16:07:18, Info CBS No startup processing required, TrustedInstaller service was not set as autostart, or else a reboot is still pending.
2011-10-13 16:07:18, Info CBS NonStart: Checking to ensure startup processing was not required.
2011-10-13 16:07:18, Error CSI 00000004@2011/10/13:20:07:18.293 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:07:20, Info CBS NonStart: Failed to get store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:20, Info CBS Failed to ensure no startup processing was required. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:20, Info CBS Failed during startup processing, continuing with Trusted Installer execution [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:20, Info CBS Startup processing thread terminated normally
2011-10-13 16:07:20, Error CSI 00000005@2011/10/13:20:07:20.641 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:07:20, Info CBS Failed to get CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:20, Error CBS Failed to initialize store parameters with boot drive: and windows directory: [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:20, Error CSI 00000006@2011/10/13:20:07:20.819 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:07:20, Info CBS Failed to get CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:20, Error CBS Failed to initialize store parameters with boot drive: and windows directory: [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:21, Error CSI 00000007@2011/10/13:20:07:21.311 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:07:21, Info CBS Failed to get CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:07:21, Error CBS Failed to initialize store parameters with boot drive: and windows directory: [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:08:18, Error CSI 00000008@2011/10/13:20:08:18.568 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:08:19, Info CBS Failed to get CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:08:19, Error CBS Failed to initialize store parameters with boot drive: and windows directory: [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:08:19, Error CSI 00000009@2011/10/13:20:08:19.165 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:08:19, Info CBS Failed to get CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:08:19, Error CBS Failed to initialize store parameters with boot drive: and windows directory: [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:08:19, Error CSI 0000000a@2011/10/13:20:08:19.773 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(6636): Error STATUS_SXS_COMPONENT_STORE_CORRUPT originated in function ComponentStore::CRawStoreLayout::OpenCanonicalDataKey expression: (null)
[gle=0x80004005]
2011-10-13 16:08:19, Info CBS Failed to get CSI store. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
2011-10-13 16:08:19, Error CBS Failed to initialize store parameters with boot drive: and windows directory: [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]


Years of membershipYears of membershipYears of membership
User avatar
Frequent Member
Frequent Member

Joined: Mon Jan 31, 2011 3:17 pm
Posts: 41
Thanks given: 30 times
Thanks received: 6 times
Location: New York, USA
 Profile E-mail  
 
Offline
 
 Post subject: Re: Sfc /scannow won't run at all :(
New postPosted: Thu Oct 13, 2011 8:36 pm 

Ok Frank thanks.


Correct me if I am wrong but by looking at this error report and some of the error and descriptions it looks like you have performed an 'Upgrade' from ????? to Windows 7 SP1.... is this the case?

Reason being it is showing error's concerning Sp1 in the way of it messed up system files and or the upgrade has too.

Also you have many errors concerning the parameters with the boot drive pointing to the windows directory too.

I also mentioned before about the 'Trusted Installer' about whether it was set to manual or automatic etc... well we have error's concerning this too.

The fact is you have so many error's it is leading me to think this was an Upgrade you performed instead of a clean install or quite possibly a very very messed up install of SP1.

But my guess is the first one.

So before I continue I think there is many things that hasn't been mentioned about your 'Issues' because you have so so many and all pointing to what I am suggesting.

Now again I could be wrong but I have seen this before and the cause was because of an upgrade.

so LOL Upgrade? or SP1 Install? or Upgrade to Windows 7 SP1?



_________________
Image
Years of membershipYears of membershipYears of membershipYears of membership
User avatar
Top Content Contributor
Top Content Contributor

Joined: Mon Nov 15, 2010 7:20 pm
Posts: 565
Thanks given: 47 times
Thanks received: 132 times
Location: UK
OS: 8 RT
 Profile E-mail  
 
Offline
Display posts from previous:  Sort by  

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to: